Results 1 to 6 of 6

Thread: Error while updating kali-linux Share/Save - My123World.Com!

  1. #1

    Error while updating kali-linux

    Dear Friends,

    I want to update and upgrade kali-linux and when i typed apt-get update && upgrade , i got the following error.

    # apt-get update && upgrade
    Get:1 http://http.kali.org kali Release.gpg [836 B]
    Get:2 http://security.kali.org kali/updates Release.gpg [836 B]
    Get:3 http://http.kali.org kali Release [21.1 kB]
    Ign http://http.kali.org kali Release
    Ign http://http.kali.org kali/main Sources/DiffIndex
    Hit http://security.kali.org kali/updates Release
    Ign http://security.kali.org kali/updates Release
    Ign http://security.kali.org kali/updates/main amd64 Packages/DiffIndex
    Ign http://http.kali.org kali/non-free Sources/DiffIndex
    Ign http://security.kali.org kali/updates/contrib amd64 Packages/DiffIndex
    Ign http://http.kali.org kali/contrib Sources/DiffIndex
    Ign http://security.kali.org kali/updates/non-free amd64 Packages/DiffIndex
    Ign http://http.kali.org kali/main amd64 Packages/DiffIndex
    Ign http://http.kali.org kali/non-free amd64 Packages/DiffIndex
    Ign http://http.kali.org kali/contrib amd64 Packages/DiffIndex
    Hit http://security.kali.org kali/updates/main amd64 Packages
    Hit http://security.kali.org kali/updates/contrib amd64 Packages
    Ign http://security.kali.org kali/updates/contrib Translation-en_US
    Hit http://security.kali.org kali/updates/non-free amd64 Packages
    Ign http://security.kali.org kali/updates/contrib Translation-en
    Ign http://security.kali.org kali/updates/main Translation-en_US
    Ign http://security.kali.org kali/updates/main Translation-en
    Ign http://security.kali.org kali/updates/non-free Translation-en_US
    Ign http://security.kali.org kali/updates/non-free Translation-en
    Get:4 http://http.kali.org kali/main Sources [7,570 kB]
    Ign http://http.kali.org kali/contrib Translation-en_US
    Ign http://http.kali.org kali/contrib Translation-en
    Ign http://http.kali.org kali/main Translation-en_US
    Ign http://http.kali.org kali/main Translation-en
    Ign http://http.kali.org kali/non-free Translation-en_US
    Ign http://http.kali.org kali/non-free Translation-en
    Hit http://http.kali.org kali/non-free Sources
    Hit http://http.kali.org kali/contrib Sources
    Hit http://http.kali.org kali/main amd64 Packages
    Hit http://http.kali.org kali/non-free amd64 Packages
    Hit http://http.kali.org kali/contrib amd64 Packages
    Fetched 7,593 kB in 59s (127 kB/s)
    Reading package lists... Done
    W: GPG error: http://http.kali.org kali Release: The following signatures were invalid: KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400
    W: GPG error: http://security.kali.org kali/updates Release: The following signatures were invalid: KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400
    bash: upgrade: command not found


    If you say only to type apt-get update then i have done it already but still same error

    Thank You!

  2. #2
    Garage Addict 41.w4r10r's Avatar
    Join Date
    Jul 2010
    Location
    Pune
    Posts
    338
    Blog Entries
    3
    Hi MikroTik,

    Running this command should fix your issue:

    Code:
    apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6


    Source: https://forums.kali.org/showthread.p...apt-get-update

  3. #3
    Garage Addict 41.w4r10r's Avatar
    Join Date
    Jul 2010
    Location
    Pune
    Posts
    338
    Blog Entries
    3
    Hi MikroTik,

    Running this command should fix your issue:

    Code:
    apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6


    Source: https://forums.kali.org/showthread.p...apt-get-update

  4. #4

    apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6

    Hello,

    Thanks for the answer. This resolved the issue

    Best Regards,
    MikroTik
    [*] To follow the path: look to the master, follow the master, walk with the master, see through the master,
    ------> become the master!!! <------

  5. #5

    Re:

    Agree what's said in previous reply. That's likely due to older version kali-archive-keyring.

  6. #6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •